Konfigurasi BGP pada GNS3 – BGP (Border Gateway Protocol) adalah salah satu jenis protokol routing yang berfungsi untuk mempertukarkan informasi antar Autonomous System (AS). BGP ini merupakan sebuah Dinamic Routing dan pada mikrotik sendiri terdapat beberapa macam fitur dinamic routing selain BGP seperti OSPF dan RIP. Untuk pertukaran informasi BGP ini memanfaatkan protokol TCP sehingga tidak perlu lagi menggunakan protokol jenis lain untuk mengangani fragmentasi, retransmisi, acknowledgement dan sequencing.

Pada post kali ini saya akan membahas Bagaimana Konfigurasi BGP pada GNS3. Pada tutorial ini IOS yang akan dipakai adalah IOS router c3600, jika belum punya bisa download disini . Untuk cara menambahkan IOS baru bisa ikuti tutorial Cara Menambahkan IOS Router pada GNS3

Konfigurasi pada Network Adapter seperti gambar dibawah ini :

 

Network Adapter GNS3

Network Adapter GNS3

Topologi Jaringan yang akan kita buat adalah seperti ini :

Topologi BGP

Topologi BGP

  • Konfigurasi Interface
    1. Buat sebuah topologi jaringan seperti diatas
    2. Lalu Start semua PC dan Router nya
    3. Buka console pada R1, lalu tuliskan syntax berikut :
R1#conf term
R1(config) #interface loopback 0
R1(config-if)# ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 0/0
R1(config-if)#ip address 192.168.13.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface fastEthernet 1/0
R1(config-if)# ip address 192.168.12.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#exit
R1#copy running-config startup-config

4. Buka console pada R2, lalu tuliskan syntax berikut :

R2#conf term
R2(config) #interface loopback 0
R2(config-if)# ip address 192.168.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 0/0
R2(config-if)#ip address 192.168.12.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 1/0
R2(config-if)# ip address 192.168.24.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface fastEthernet 2/0
R2(config-if)# ip address 192.168.23.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#exit
R2#copy running-config startup-config

5. Kemudian Buka console pada R3, lalu tuliskan syntax berikut :

R3#conf term
R3(config) #interface loopback 0
R3(config-if)# ip address 192.168.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 0/0
R3(config-if)#ip address 192.168.13.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 1/0
R3(config-if)# ip address 192.168.34.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface fastEthernet 2/0
R3(config-if)# ip address 192.168.23.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#exit
R3#copy running-config startup-config

6. Buka console pada R4, lalu tuliskan syntax berikut :

R4#conf term
R4(config) #interface loopback 0
R4(config-if)# ip address 192.168.4.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 192.168.24.4 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#interface fastEthernet 1/0
R4(config-if)# ip address 192.168.34.1 255.255.255.0
R4(config-if)#no shutdown
R4(config-if)#exit
R4(config)#exit
R4#copy running-config startup-config
  • Konfigurasi BGP
    7. Buka console pada R1, lalu tuliskan syntax berikut :

    R1#conf term
    R1(config)#router bgp 12
    R1(config-router)#network 192.168.1.0 mask 255.255.255.0
    R1(config-router)#neighbor 192.168.12.2 remote-as 12
    R1(config-router)#neighbor 192.168.12.2 next-hop-self
    R1(config-router)#neighbor 192.168.12.2 soft-reconfiguration inbound
    R1(config-router)#neigbor 192.168.13.3 remote-as 60
    R1(config-router)#neighbor 192.168.13.3 soft-reconfiguration inbound
    R1(config-router)#exit
    R1(config)#exit
    R1#copy running-config startup-config
    

    8. Buka console pada R2, lalu tuliskan syntax berikut :

    R2#conf term
    R2(config)#router bgp 12
    R2(config-router)#network 192.168.2.0 mask 255.255.255.0
    R2(config-router)#neighbor 192.168.12.1 remote-as 12
    R2(config-router)#neighbor 192.168.12.1 next-hop-self
    R2(config-router)#neighbor 192.168.12.1 soft-reconfiguration inbound
    R2(config-router)#neighbor 192.168.23.3  remote-as 60
    R2(config-router)#neighbor 192.168.23.3  soft-reconfiguration inbound
    R2(config-router)#neighbor 192.168.24.4  remote-as 64
    R2(config-router)#neighbor 192.168.24.4  soft-reconfiguration inbound
    R2(config-router)#exit
    R2(config)#exit
    R2#copy running-config startup-config
    

    9. Buka console pada R3, lalu tuliskan syntax berikut :

    R3#conf term
    R3(config)#router bgp 60
    R3(config-router)#network 192.168.3.0 mask 255.255.255.0
    R3(config-router)#neighbor 192.168.13.1 remote-as 12
    R3(config-router)#neighbor 192.168.13.1 soft-reconfiguration inbound
    R3(config-router)#neighbor 192.168.23.2 remote-as 12
    R3(config-router)#neighbor 192.168.23.2 soft-reconfiguration inbound
    R3(config-router)#neighbor 192.168.34.1 remote-as 64
    R3(config-router)#neighbor 192.168.34.1 soft-reconfiguration inbound
    R3(config-router)#exit
    R3(config)#exit
    R3#copy running-config startup-config
    

    10. Buka console pada R4, lalu tuliskan syntax berikut :

    R4#conf term
    R4(config)#router bgp 64
    R4(config-router)#network 192.168.4.0 mask 255.255.255.0
    R4(config-router)#neighbor 192.168.34.3 remote-as 60
    R4(config-router)#neighbor 192.168.34.3 soft-reconfiguration inbound
    R4(config-router)#neighbor 192.168.24.2 remote-as 12
    R4(config-router)#neighbor 192.168.24.2 soft-reconfiguration inbound
    R4(config-router)#exit
    R4(config)#exit
    R4#copy running-config startup-config
    

    11. Selesai. Untuk menguji apakah konfigurasi berhasil atau tidak dapat menggunakan perintah ping
    – Ping dari R4 ke R1

    Ping R4 ke R1

    Ping R4 ke R1

Sekian tutorial mengenai Konfigurasi BGP pada GNS3.

Jika ada pertanyaan, silahkan tulis di kolom komentari. Terima Kasih 🙂

Posted by Luqman Hakim

I am Luqman Hakim, founder of this blog. I am Software Engineer and IT Security Enthusiast from Indonesia. I spend most of my time in doing programming and playing CTF (Capture the Flag)

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.