Konfigurasi Routing OSPF Multi Area pada GNS3 – Open Shortest Path First (OSPF) adalah sebuah protokol routing otomatis (Dynamic Routing) yang mampu menjaga, mengatur dan mendistribusikan informasi routing antar network mengikuti setiap perubahan jaringan secara dinamis. OSPF termasuk di dalam kategori IGP (Interior Gateway Protocol) yang memiliki kemapuan Link-State dan Alogaritma Djikstra yang jauh lebih efisien dibandingkan protokol IGP yang lain. Sebelumnya saya sudah pernah membagikan OSPF juga, namun pada posting sebelumnya hanya OSPF biasa. Pada posting ini saya akan membagikan tutorial yang OSPF Multi Area.

Langsung saja, pada tutorial ini IOS yang akan dipakai adalah IOS router c3600, jika belum punya bisa download disini . Untuk cara menambahkan IOS baru bisa ikuti tutorial Cara Menambahkan IOS Router pada GNS3

Konfigurasi pada Network Adapter seperti gambar dibawah ini :

 

Network Adapter GNS3

Network Adapter GNS3

Topologi Jaringan yang akan kita buat adalah seperti ini :

Topologi OSPF MultiArea

Topologi OSPF MultiArea

  1. Buat sebuah topologi jaringan seperti diatas
  2. Lalu Start semua PC dan Router nya
  3. Buka console pada R1, lalu tuliskan syntax berikut :
    R1#conf term
    R1(config)#interface fastEthernet 0/0
    R1(config-if)# ip address 192.168.60.1 255.255.255.252
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#interface fastEthernet 1/0
    R1(config-if)#ip address 10.1.1.1 255.255.255.0
    R1(config-if)#no shutdown
    R1(config-if)#exit
    R1(config)#router ospf 60
    R1(config-router)# router-id 1.1.1.1
    R1(config-router)# network 10.1.1.0 0.0.0.255 area 1
    R1(config-router)# network 192.168.60.0 0.0.0.3 area 0
    R1(config-router)#exit
    R1(config)#exit
    R1#copy running-config startup-config
    
  4. Buka console pada R2, lalu tuliskan syntax berikut :
    R2#conf term
    R2(config)#interface fastEthernet 0/0
    R2(config-if)# ip address 192.168.60.2 255.255.255.252
    R2(config-if)#no shutdown
    R2(config-if)#exit
    R2(config)#interface fastEthernet 1/0
    R2(config-if)#ip address 192.168.64.2 255.255.255.252
    R2(config-if)#no shutdown
    R2(config-if)#exit
    R2(config)#router ospf 64
    R2(config-router)# router-id 2.2.2.2
    R2(config-router)# network 192.168.60.0 0.0.0.3 area 1
    R2(config-router)# network 192.168.64.0 0.0.0.3 area 2
    R2(config-router)#exit
    R2(config)#exit
    R2#copy running-config startup-config
    
  5. Buka console pada R3, lalu tuliskan syntax berikut :
    R3#conf term
    R3(config)#interface fastEthernet 0/0
    R3(config-if)# ip address 192.168.64.1 255.255.255.252
    R3(config-if)#no shutdown
    R3(config-if)#exit
    R3(config)#interface fastEthernet 1/0
    R3(config-if)#ip address 10.2.2.1 255.255.255.0
    R3(config-if)#no shutdown
    R3(config-if)#exit
    R3(config)#router ospf 64
    R3(config-router)# router-id 3.3.3.3
    R3(config-router)# network 192.168.64.0 0.0.0.3 area 0
    R3(config-router)# network 10.2.2.0 0.0.0.255 area 2
    R3(config-router)#exit
    R3(config)#exit
    R3#copy running-config startup-config
    
  6. Setelah konfigurasi router, kemudian buka console pada PC 1 dan PC 2 lalu tuliskan syntax berikut
    – PC1:

    PC1> ip 10.1.1.2 255.255.255.0 10.1.1.1
    PC1> save
    

    – PC2:

    PC2> ip 10.2.2.2 255.255.255.0 10.2.2.1
    PC2> save
    
  7. Kemudian periksa di table routing nya
    – R1 :

    Table Routing R1

    Table Routing R1

    – R2 :

    Table Routing R2

    Table Routing R2

    – R3 :

    Table Routing R3

    Table Routing R3

  8. Dari tabel routing sebelumnya sudah dapat dilihat, jika Area sudah sesuai dengan topologi maka sudah benar

Sekian posting kali ini tentang Tutorial Konfigurasi Routing OSPF Multi Area pada GNS3

Jika ada pertanyaan silahkan tulis di kolom komentar, Terima Kasih 🙂

Posted by Luqman Hakim

I am Luqman Hakim, founder of this blog. I am Software Engineer and IT Security Enthusiast from Indonesia. I spend most of my time in doing programming and playing CTF (Capture the Flag)

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.